Как добавить пользовательские скрипты при настройки диска LiveCD

Я хочу, чтобы добавить пользовательские скрипты при принятии настройки LiveCD с Убунту.

+809
Dionizio Neto 22 окт. 2010 г., 21:54:26
26 ответов

А не "Системных настройках" делает Gnome3.8 нет заголовка, что это просто "настройки"? Я читал, что особенности частной жизни обратно в GNOME 3.8 и что вы можете найти их в разделе "Настройки"

+997
Jacob Tyler 03 февр. '09 в 4:24
  • ЗШ не установлен по умолчанию. Ты его установить?

  • Вы сможете начать ЗШ вручную, введя

    /бин/ЗШ 
    

    в приглашении?

Если вы answerded как с Да, я предлагаю вам посмотреть в /etc/passwd и. В первой строке должно быть написано

корень:х:0:0:суперпользователя:/бин/ЗШ

Если это не так, вы также можете установить его здесь, а не делать это через ЧШ. Но убедитесь, что вы действительно установили zsh и вы вступите на путь правильно или вы могли бы найти себя заблокирована из вашей системы.

+992
jaybrook 13 янв. 2016 г., 2:20:12

Это показывает количество пакетов, которые должны быть обновлены в системе.

+987
user197512 9 апр. 2014 г., 9:21:29

Существует конфликт между RabbitVCS и Ubuntu на Ubuntu 12.04 и RabbitVCS 15.2.

Что, наконец, работал для меня после того, как пришлось жить без RabbitVCS месяцами заключается в следующем:

  1. Зайдите в свой Ubuntu один настройках в настройках системы
  2. В разделе "Параметры" снимите все "файл синхронизации"
  3. Перезагрузка (возможно, также просто отключиться/но я перезагрузил)

И теперь ваш RabbitVCS должны работать как рекламируется.

+930
TiffanyTLove 13 февр. 2015 г., 3:08:26

Яркость экрана используется, чтобы затемнить через несколько секунд, чтобы сохранить батарею. Это по умолчанию в Ubuntu 12.04. Однако при просмотре видео это не должно затуманивать.

Это работает правильно, когда я смотрю видео с помощью встроенных приложений, как VLC. В браузере видео, однако, это не помешало с затемнением. Это очень раздражает, как вы должны переместить курсор каждые 10 секунд или около того.

Я использовал, чтобы использовать Mac OSX откуда у меня была такая же затемнять настроек и Флэш-ролики были сняты правильно с учетом.

Любой идея, как вы можете сделать YouTube предотвратить экран от затемнения?

+927
Albert Tran 12 июн. 2011 г., 0:26:05

Попробуйте параллельно-СШ он был переименован.

Цитата из описания пакета:

 Пакет содержит:
.
 - Параллельно СШ (параллельно-СШ, вверх по течению называет ее ПСШ), выполняет команды на
 несколько узлов параллельно
 - Параллельно УПП (параллельно-УПП, вверх по течению называет его программе pscp), копирует файлы
 несколько удаленных узлов параллельно
 - Параллельно при помощи rsync (параллельно-через вышестоящий называет это prsync), эффективно
 копирует файлы в несколько узлов параллельно
 - Параллельно нюк (параллельно-нюк, вверх по течению называет его pnuke), убивает процессы на
 несколько удаленных узлов параллельно
 - Параллельно хлебать (параллельно хлебать, вверх по течению называет его pslurp), копирует файлы
 из нескольких удаленных узлов в центральный узел параллельно
.
 Эти инструменты хорошо подходят для управления большими коллекциями узлов, где быстрее
 альтернативы, такие как gexec и PCP не имеется.
+875
sunsetsurf 23 окт. 2017 г., 20:13:24

Я пытаюсь установить MS Office 2010 на Убунту 12.04 на мой новый МасВоок Pro (15").

Я уже читал и следил за каждым существующие темы на форуме и следили за каждым существующим учебником, но моя проблема покажется уникальным, поскольку какое бы решение я попробовать, проблема остается.

Когда я запускаю чипов в Linux, две коробки друг за другом появляются (перед последним обновлением Убунту на прошлой неделе, второе окно не появляется, только в первый раз); первый говорит мне:

Ошибка: PlayOnLinux является не удалось найти 32-битный OpenGL библиотеки. Вы могут возникнуть проблемы с вашими играми".

Когда я закрываю это окно, второе всплывает, заявив:

Ошибка: не удается найти чипов в Linux с 7z. Вы должны установить его для использования чипов в Linux.

Конечно, я пробовал продувать чипов в Linux (удалить его и повторно установить его). Я также пробовал другие версии этих чипов в Linux. Ничто не имеет значения: проблема остается.

Я до сих пор не удалось установить 32-битные библиотеки для OpenGL, так как у меня Radeon видеокарты (которые, казалось бы, необычного) и я просто не могу найти эти библиотеки.

После того, как две "ошибки" ящики закрыты, PlayOnLinux является открытым, но не похоже, чтобы работать должным образом; когда я пытаюсь установить Microsoft Office 2010 с, ничего не происходит.

Когда я пытаюсь закрыть чипов в Linux, то это еще хуже: единство, кажется, не удалось закрыть его (у меня даже были заморожены экран при попытке xkill его через терминал).

Я с нетерпением жду любых советов, которые могут помочь.

P. S.: В 01:совместимый контроллер VGA с 00.0: предварительные микро-приборы [драмов] в девичестве АТИ Уистлер [видеокарты AMD Radeon серии HD 6600M серий]
+834
currarpickt 11 окт. 2018 г., 9:41:52

Чипов в Linux и Kindle для ПК в список программного обеспечения и устанавливает соответствующее вино версия для него. В моем случае он скачал вино 1.4. и тогда Kindle для ПК может быть установлен и запущен из чипов в Linux.

+732
Reds 30 дек. 2014 г., 1:38:16

Я использую Ubuntu 12.10 64bit с Gnome3 и fglrx от-обновления графических драйверов. Водители хорошие работы, т. е. с Гримрок(вино), OilRush или Rochard. Теперь я купил HumbleIndieBundle7 и хотите играть DungeonDefenders. Я извлек архив и нашла ./DungeonDefenders скрипт в эту папку. Когда я запускаю этот скрипт, экран всплеска в игре появляется, длится несколько секунд и снова исчезает. Потом программа закончилась. Через терминал я вижу следующий выход:

[email protected]:~/Arbeitsfläche/DungeonDefenders$ ./DungeonDefenders
Подземелье защитников: установлен в '/дом/chocobai/Arbeitsfläche/DungeonDefenders'.
*** в glibc обнаружена *** ./DungeonDefenders-для x86: бесплатно(): недопустимый указатель: 0x0a9e9118 ***
======= След: =========
в /lib/i386 в-линукс-дистрибутив GNU/библиотеки libc.так.6(+0x75ee2)[0xf7224ee2]
/home/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/Binaries/libSDL2-2.0.so.0(+0xb8072)[0xf7590072]
/home/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/Binaries/libSDL2-2.0.so.0(SDL_VideoQuit+0x6e)[0xf756f2de]
/home/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/Binaries/libSDL2-2.0.so.0(SDL_QuitSubSystem+0x16d)[0xf74e1f3d]
/home/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/Binaries/libSDL2-2.0.so.0(SDL_Quit+0x28)[0xf74e2018]
./DungeonDefenders-х86[0x9aff07b]
в /lib/i386 в-линукс-дистрибутив GNU/библиотеки libc.так.6(+0x32f51)[0xf71e1f51]
======= Карту памяти: ========
08048000-0a4b5000 р-на XP 00000000 08:03 37486660 /дома/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/бинарники/DungeonDefenders-х86
0a4b5000-0a4b6000 Р-хр 0246c000 08:03 37486660 /дома/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/файлы/DungeonDefenders-х86
0a4b6000-0a502000 rwxp 0246d000 08:03 37486660 /дома/chocobai/Arbeitsfläche/DungeonDefenders/UDKGame/бинарники/DungeonDefenders-х86
0a502000-0a5e2000 rwxp 00000000 00:00 0
0a9be000-0ba5b000 rwxp 00000000 00:00 0 [кучи]
f0b56000-f0d56000 rwxs ef586000 00:05 9778 /Дев/АТИ/card0
f1100000-f11b2000 rwxp 00000000 00:00 0
f11b2000-f1200000 ---п 00000000 00:00 0
f1300000-f13ab000 rwxp 00000000 00:00 0
f13ab000-f1400000 ---п 00000000 00:00 0
f14c1000-f14c2000 ---п 00000000 00:00 0
f14c2000-f1cc2000 rwxp 00000000 00:00 0
f1cc2000-f1cc3000 ---п 00000000 00:00 0
f1cc3000-f24c3000 rwxp 00000000 00:00 0
f2600000-f2621000 rwxp 00000000 00:00 0
f2621000-f2700000 ---п 00000000 00:00 0
f27ff000-f2800000 ---п 00000000 00:00 0
f2800000-f3000000 rwxp 00000000 00:00 0 [стек:20940]
f3000000-f3021000 rwxp 00000000 00:00 0
f3021000-f3100000 ---п 00000000 00:00 0
f3129000-f3169000 rwxs 00027000 00:05 9778 /Дев/АТИ/card0
f3169000-f316a000 ---п 00000000 00:00 0
f316a000-f396a000 rwxp 00000000 00:00 0 [стек:20936]
f396a000-f396b000 ---п 00000000 00:00 0
f396b000-f416b000 rwxp 00000000 00:00 0 [стек:20935]
f419f000-f41a0000 rwxp 00000000 00:00 0
f41a0000-f41a7000 Р-хз 00000000 08:01 1312550 в /usr/lib в/для i386-линукс-дистрибутив GNU/gconv/gconv-модулей.кэш
f41a7000-f48a7000 rwxs 00006000 00:05 9778 /Дев/АТИ/card0
f48a7000-f4b27000 rwxp 00000000 00:00 0
f4b27000-f4b75000 р-на XP 00000000 08:01 417564 в /usr/lib32/fglrx от/libatiadlxx.так
f4b75000-f4b77000 rwxp 0004e000 08:01 417564 в /usr/lib32/fglrx от/libatiadlxx.так
f4b77000-f4b87000 rwxp 00000000 00:00 0
f4bac000-f6dbb000 р-на XP 00000000 08:01 417567 в /usr/lib32/fglrx от/из DRI/fglrx_dri.так
f6dbb000-f6ed0000 rwxp 0220e000 08:01 417567 в /usr/lib32/fglrx от/из DRI/fglrx_dri.так
f6ed0000-f6f9b000 rwxp 00000000 00:00 0
f6f9b000-f6f9f000 р-на XP 00000000 08:01 1313273 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXxf86vm.так.1.0.0
f6f9f000-f6fa0000 Р-хр 00003000 08:01 1313273 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXxf86vm.так.1.0.0
f6fa0000-f6fa1000 rwxp 00004000 08:01 1313273 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXxf86vm.так.1.0.0
f6fa1000-f6fa3000 р-на XP 00000000 08:01 1313796 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXss.так.1.0.0
f6fa3000-f6fa4000 Р-хр 00001000 08:01 1313796 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXss.так.1.0.0
f6fa4000-f6fa5000 rwxp 00002000 08:01 1313796 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXss.так.1.0.0
f6fa5000-f6fae000 р-на XP 00000000 08:01 1313187 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrandr.так.2.2.0
f6fae000-f6faf000 Р-XP с 00008000 08:01 1313187 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrandr.так.2.2.0
f6faf000-f6fb0000 rwxp 00009000 08:01 1313187 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrandr.так.2.2.0
f6fb0000-f6fb2000 р-на XP 00000000 08:01 1313185 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXinerama.так.1.0.0
f6fb2000-f6fb3000 Р-хр 00001000 08:01 1313185 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXinerama.так.1.0.0
f6fb3000-f6fb4000 rwxp 00002000 08:01 1313185 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXinerama.так.1.0.0
f6fb4000-f6fb9000 р-на XP 00000000 08:01 1312921 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXfixes.так.3.1.0
f6fb9000-f6fba000 Р-хр 00004000 08:01 1312921 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXfixes.так.3.1.0
f6fba000-f6fbb000 rwxp 00005000 08:01 1312921 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXfixes.так.3.1.0
f6fbb000-f6fc3000 р-на XP 00000000 08:01 1312775 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrender.так.1.3.0
f6fc3000-f6fc4000 Р-хр 00007000 08:01 1312775 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrender.так.1.3.0
f6fc4000-f6fc5000 rwxp 00008000 08:01 1312775 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXrender.так.1.3.0
f6fc5000-f6fce000 р-на XP 00000000 08:01 1313181 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXcursor.так.1.0.2
f6fce000-f6fcf000 Р-XP с 00008000 08:01 1313181 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXcursor.так.1.0.2
f6fcf000-f6fd0000 rwxp 00009000 08:01 1313181 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXcursor.так.1.0.2
f6fd0000-f7014000 rwxp 00000000 00:00 0
f7014000-f7019000 р-на XP 00000000 08:01 1312733 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXdmcp.так.6.0.0
f7019000-f701a000 Р-хр 00004000 08:01 1312733 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXdmcp.так.6.0.0
f701a000-f701b000 rwxp 00005000 08:01 1312733 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXdmcp.так.6.0.0
f701b000-f701d000 р-на XP 00000000 08:01 1312731 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXau.так.6.0.0
f701d000-f701e000 Р-хр 00001000 08:01 1312731 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXau.так.6.0.0
f701e000-f701f000 rwxp 00002000 08:01 1312731 в /usr/lib в/для i386-линукс-дистрибутив GNU/libXau.так.6.0.0
f701f000-f703f000 р-на XP 00000000 08:01 1312735 в /usr/lib в/для i386-линукс-дистрибутив GNU/libxcb.так.1.1.0
f703f000-f7040000 Р-хр 0001f000 08:01 1312735 в /usr/lib в/для i386-линукс-дистрибутив GNU/libxcb.так.1.1.0
f7040000-f7041000 rwxp 00020000 08:01 1312735 в /usr/lib в/для i386-линукс-дистрибутив GNU/libxcb.так.1.1.0
f7041000-f7173000 р-на XP 00000000 08:01 1312737 в /usr/lib в/для i386-линукс-дистрибутив GNU/libX11.так.6.3.0 Abgebrochen
[email protected]:~/Arbeitsfläche/DungeonDefenders$ 

Я вижу, что скрипт бинарного файла в этой папке Вит x86 в название. Интересно, будет ли игра не совместима с 64-битной систем? Похоже, он пытается выполнить binarys для других архитектур. Это вообще проблема, я могу решить, или я должен связаться с скромный поддержка? Или я делаю что-то неправильно? Этот рецепт выглядит так:

#!/Бен/ш

# этот скрипт для Linux!

FindPath()
{
 Х=`что "$1"`
 Более ранних версий -э г=`"$х"`
 каталог "$г"
}

если [ "${DUNDEF_DATA_PATH}" = "" ]; затем
 DUNDEF_DATA_PATH="`FindPath "$0"`"
интернет

Эхо "подземелье защитники: установлен в '$DUNDEF_DATA_PATH'."
компакт-диск "$DUNDEF_DATA_PATH/UDKGame/бинарники"

ОТВ ./DungeonDefenders-х86 "[email protected]"

Я не могу представить, что эта игра работает только на 32bit и они не говорят клиентам об этом. Спасибо за советы.

PS: кроме х86 двоичной альтернативы нет в этой папке:

[email protected]:~/Arbeitsfläche/DungeonDefenders/UDKGame/бинарники$ ЛС
DungeonDefenders-х86 libopenal.так.1 libSDL2-2.0.так.0 кода валюты XDG-открытые
+706
Isa Souza 10 авг. 2016 г., 17:09:22

Когда я скопировать веб-страницу из моей локальной машине (Mac), чтобы мой удаленный сервер (Убунту), специальные символы в текст не заканчивается в квадраты в браузере или вопрос-метки-символы в терминале.

Я старался копировать их с SCP или FTP; такие же проблемы.

Я проверил языка на сервере: язык=язык.В UTF-8. Это представляется правильным и не должно быть все равно проблема, потому что, когда я изменить файл в терминале на сервере, специальные символы отображаются как они должны.

Уже искал в течение нескольких часов, но не могу найти решение. Кто-нибудь идея?

+693
user2051770 19 окт. 2019 г., 9:01:59

в веб-браузере перейдите к http://localhost:631/ войти с паролем логин и добавить принтер этак

+603
mattcholawo 20 дек. 2016 г., 7:32:53

Пользователь кроме TS3 на Убунту форумах написал решение, которое работало для меня, наконец, после столь долгой борьбы. Так что если вы столкнулись с той же проблемой, как и я, проверить его на http://ubuntuforums.org/showthread.php?t=1889170

Вот его резюме:

  1. Б-43 установщик не поддерживают BCM4313 (4727)
  2. В bcmwl-ядро-источник драйверов (нашел в Центре приложений Ubuntu) поддерживает его, но сначала нужно убедиться, что
    1. b43 и опцию, чтобы активировать драйверы ГНАУ от Broadcom через системные настройки -> дополнительные драйверы не будут удалены/отключены
    2. что эти драйверы (в43, всма, brcsmac) находятся в черном списке и
    3. что драйвер WL, которые работает не в черном списке

Смотрите ссылку для деталей.

+578
coryknapp 15 сент. 2011 г., 18:38:45

Можно связать псевдоним для конкретных версий Java. Просто добавьте следующие строки в ваш $дома/.bashrc следующее:

java6 псевдоним='/путь/к/java6/ОГРН/Ява'
java7 псевдоним='/путь/к/java7/ОГРН/Ява'

Же самое для javac и все будет хорошо ;-)

+561
ronnix 7 июн. 2011 г., 16:48:00

WinFF-это графическая оболочка для командной строки видео-конвертер, кодек ffmpeg.

Это будет наиболее конвертировать любые видео файлы, что ffmpeg будет конвертировать. WinFF делает несколько файлов в различные форматы за один раз. Вы можете, например, конвертировать mpeg в файлы, и мову, все в Ави все сразу.

WinFF доступна для Debian, Убунту, Редхат на основе дистрибутивов GNU/Линукс. WinFF доступна в бразильский португальский, болгарский, китайский традиционный, датский, английский, французский, немецкий, греческий, иврит, итальянский, норвежский, польский, португальский, русский, сербский, словенский, испанский и турецкий.

Это может обеспечить более простое решение, а не Кинк.

Для установки судо apt-получить установку winff

Учебник

enter image description here

+555
Stephanie Mayo 17 сент. 2015 г., 14:44:29

В Ubuntu один пусковой задержки 30 секунд после запуска сессии перед началом syncdaemon. Тогда syncdaemon может занять несколько минут, прежде чем он жив и здоров и отвечать на запросы. Так что, если вы будете ждать 30 секунд после запуска программы, вы сможете открыть терминал и увидеть процесс с ПС-с ubuntuone-syncdaemon.

Если вы обнаружите, что оно не начиналось, в тот же терминал, пожалуйста

в /usr/lib в/ubuntuone-клиент/ubuntuone-syncdaemon --отладка

и сайт Pastebin выходной, чтобы мы могли добраться до корня проблемы.

+555
ana marie 25 янв. 2011 г., 2:53:14

Как правило, в Xfce сочетания клавиш сочетания клавиш сочетание клавиш Ctrl+клавишу F5 настроен, чтобы переключиться на рабочий стол 5, Если вы не имеете рабочего пространства 5, затем нажать сочетание клавиш Ctrl+Ф5 не будет ничего делать.

Чтобы решить ее Гото

Меню Приложения > Настройки > Диспетчер > Диспетчер Окон

проверьте клавиатуру на вкладке и найти вариант, который имеет сочетание клавиш Ctrl+клавишу F5 настроен как "быстрые" клавиши,

понятно, что "быстрые" клавиши.

вы должны быть в состоянии использовать сочетание клавиш Ctrl+клавишу F5 ключ теперь для Chrome.

+552
bashlock 28 окт. 2019 г., 16:06:56

После ввода, например, браузер Firefox & или , если & в терминал, повторил вывод выглядит

[число фоновых запущенных программ] <неизвестный номер>

Что это число означает?

Кроме того, что они всегда растут, они, кажется, не следовать какой-либо конкретной целью, они какие-то показатели?

+477
mariralph 18 сент. 2019 г., 15:46:11

АПТ-это система управления пакетами в Debian и других Linux-дистрибутивов на его основе, таких как Ubuntu. По большей части, склонны легко использовать для установки, удаления и обновления пакетов. В редких случаях, часто, когда вы смешиваете в сторонних зависимостей, то есть шанс, что apt-получить может в конечном итоге дать вам сообщение об ошибке говорит вам, что пакет установки не могла быть завершена.

Решения:

Это всегда хорошая идея для резервного копирования конфигурационных файлов, как /и т. д./кв/источников.список, так что вы можете отменить изменения, если это необходимо.

  • Если ошибка показывает что-то вроде этого:

    <некоторые-пакета>: зависит: <другой-пакет> ( = ), а этот-версия должна быть установлена

    Затем убедитесь, что ограничен и Вселенной репозитории подключены. Нажмите АЛТ+Ф2, тип программного обеспечения-свойства-ГТК и нажмите Ввод.

    Под Убунту софта вкладке, включить все репозитории.

  • Одной из возможных причин неудовлетворенных зависимостей может быть поврежден пакет базы данных, и/или некоторые пакеты не были установлены правильно. Чтобы исправить эту проблему, нажмите клавишу Alt+комбинацию клавиш Ctrl+T для открытия терминала и попытаться выполнить одну из следующих команд:

    суда apt-получить чистый

    или,

    судо apt-получить автоочистка

    apt-получить чистые очищает локальное хранилище извлеченных пакет файлов (.deb файлы). Он удаляет все, но блокировка файла из /VAR/кэш/АПТ/архивы/ и /VAR/кэш/кв./архив/частично/. apt-получить автоочистка очищает локальное хранилище извлеченных файлов пакета, но в отличие от apt-получить чистый, он удаляет только файлы пакета, которые больше не могут быть загружены, и во многом бесполезно.

  • Одним из самых основных исправлений для решения проблемы зависимости-это выполнить:

    суда apt-получить -Ф установите

    К здесь означает “чиню”. АПТ попытается исправить сломанные зависимости. Если вы вручную установили пакет, который имел неудовлетворенные зависимости, программа apt-вам будет установить эти зависимости, если это возможно, в противном случае он может просто удалить пакет, который вы установили для того, чтобы решить проблему.

    Затем выполните:

    судо команды dpkg --настроить -а

    Затем снова запустите этого:

    суда apt-получить -Ф установите

    Если выходными данными является:

    0 обновлено, 0 установлено новых, 0 для удаления и 1 пакетов не обновлено.

    Это означает, что это не удалось.

  • Следующее решение-это выполнить:

    суда apt-получить -у дист-апгрейд

    Если он показывает каких-либо пакетов, то лучше устранить их. Пакеты проходят из-за зависимостей конфликты, которые склонны не удается разрешить. Попробуйте эту команду, чтобы найти и устранить конфликты:

    суда apt-получить -вывода отладочных::pkgProblemResolver=да дист-апгрейд

    Если он не может устранить конфликты, он выйдет с:

    0 обновлено, 0 установлено новых, 0 для удаления и 6 не обновляется.

    Удалить проходят пакеты по одному, бег дист-апгрейд каждый раз, пока нет больше пакетов. Затем повторно установить все необходимые пакеты. Будьте уверены, чтобы использовать --"сухой ход" вариант, так что вы полностью информированы о последствиях:

    судо apt-получить удалить --сух-пакет-название

    После удаления пакета, который вы пытаетесь установить не может быть идеальным, вы можете также попробовать найти в репозитории пакеты нужно удовлетворить зависимости.

Наконец, если все остальное терпит неудачу, вы можете попытаться удовлетворить зависимости самостоятельно, либо поиск и установка необходимых пакетов, или установив их источник, а затем создать “деб” пакеты для них.

Отключить/Удалить/Очистить ППД:

ППД (персональных архивов пакетов), хранилища, размещенного на панели запуска. Вы можете использовать ППД, чтобы установить или обновить пакеты, которые не доступны в официальных репозиториях Ubuntu.

Одна из самых распространенных причин неудовлетворенных зависимостей ППД, особенно, когда используется для обновления существующего пакета в репозитории Ubuntu. Для решения проблемы у вас есть три варианта: отключение, продувка (вернуться к оригинальной пакет в репозитории Ubuntu) или удалить ППА.

  • Отключить:

    Отключение ППА означает нет больше обновлений для установленных пакетов от ППА. Чтобы отключить НПА: открыт Центр программного обеспечения > правка > источники приложений или,

    Нажмите АЛТ+Ф2 и запускать программы-свойства-ГТК.

    Нажмите на другое программное обеспечение вкладку, вы увидите, что каждый НПА иметь две линии, одна для скомпилированных пакетов и один для источника, снимите обе линии на отключении ППА. Здесь вы также можете добавлять и удалять ППД.

  • Продувки:

    Очистка ППА означает, понижение пакетов в выбранном ППА к версии в официальных репозиториях Ubuntu и отключение, что ППА. ППА продувки делает именно это. Для установки ППА продувки выполните следующую команду:

    суда apt-получить установку ППА-продувки

Но, рассматривая вопрос АПТ сломан, приведенная выше команда будет выполнена. Так что используйте эту команду

команды mkdir ППА-продувка && компакт-диск ППА-продувка && wget для http://mirror.pnl.gov/ubuntu/pool/universe/p/ppa-purge/ppa-purge_0.2.8+bzr56_all.деб && wget для http://mirror.pnl.gov/ubuntu//pool/main/a/aptitude/aptitude_0.6.6-1ubuntu1_i386.deb && судо команды dpkg -я ./*.деб

Использовать ППА продувки:

судо ППА-ППА продувки:someppa/ППА

Если ППА-прочисти команда не выполняется по какой-то причине, вы не можете запустить 'ППА-прочисти еще раз, если вы повторно включите ППА (для включения НПА выполните те же действия, как отключение ППА и проверить обе линии конкретного НПА, чтобы включить его).

Примечание: ППА продувки не убрать ППД (может быть в будущем), так что вам придется вручную удалить ППА.

  • Удалить:

    Если пакет установлен из НПА не существует в официальных репозиториях Убунту, то через ППА продувки не рекомендуется, потому что нет ничего, чтобы быть понижен и ППА очистить не удалить его либо. Чтобы удалить PPA и установить пакеты выполните следующие команды: (игнорировать первую команду, если вы не хотите удалять установленные пакеты)

    судо apt-получить autoremove --имя-пакета продувки 
    судо дополнения кв-хранилище удалить ППА:someppa/ППА
    судо apt-получить автоочистка
    

В качестве альтернативы можно использовать г ППА диспетчер , чтобы отключить/удалить/очистить НПА (реквизиты в конце ответа).

Профилактические Меры:

Так как мы можем избежать этой ситуации в первую очередь?

  • Сохранить Ubuntu вплоть до даты. В Ubuntu автоматически уведомляет о наличии обновлений, вы также можете проверить наличие обновлений, нажав на сессии индикатор в единстве панели:

    Или, нажмите клавишу Alt+комбинацию клавиш Ctrl+Т , чтобы открыть терминал и выполнить следующие команды:

    судо apt-получить обновление
    судо apt-получить обновление

    Обновление: синхронизация списка доступных пакетов с сервера в репозитории исходного кода. Обновления: загружает и устанавливает каких-либо новых версий установленных пакетов.

  • Если вы решите добавить другие репозитории источников.список, убедитесь, что репозиторий может работать (и работает) с Ubuntu. Репозитории, которые не предназначены для работы с вашей версии Ubuntu может внести несогласованность в вашей системе и, возможно, заставит вас заново установить. Кроме того, убедитесь, что вам действительно нужно, чтобы добавить сторонние репозитории как программный пакет(ы) вы ищете, возможно, уже внесен в официальных репозиториях! Источник
  • Удалить дубликаты ППД. Г ППА менеджер (руководство по установке в конце ответа), можно легко просканировать и удалить дубликаты ППД.

    • Нажмите АЛТ+Ф2 и запустить г-ППА-менеджер для открытия г ППА менеджер.
    • После открытия двойной клик или нажмите Войти на передовой.
    • В появившемся окне выберите Сканировать и удалить дубликаты ППД и нажмите кнопку ОК.

enter image description here

Получение Справки:

Когда просят помощи на Askubuntu или любую другую помощь форума, вам следует включить вывод команды в ваш вопрос:

  • Выход фактических ошибок:

    суда apt-получить установку имя пакета
  • Это покажет ваши источники.список:

    кошка /и т. д./кв/источников.список
  • Это покажет список ППД (если таковые имеются):

    кошка /и т. д./кв/источников.список.д/*

Дополнительные Источники:


Г ППА менеджер: Г ППА Manager является одна остановка магазин для всех ваших потребностей ППА.

y ppa manager

Вот некоторые из его особенностей:

  • поиск в все запуска ППД
  • список и загрузка пакетов в НПА
  • добавить / удалить / удалить ППА
  • резервное копирование и восстановление ППА источники
  • удалить дубликаты ППА источники

Для установки г ППА менеджера, откройте терминал, нажав клавишу Alt+комбинацию клавиш Ctrl+Т и выполните следующие команды:

судо дополнения кв-репозиторий ppa:webupd8team/г-ППА-менеджер
судо apt-получить обновление
судо apt-получить установку г-ППА-менеджер

Рассматривая вопрос, АПТ сломано, так используйте эти команды вместо

судо Су

и

32 бит:

команды mkdir г-ППА-менеджер && диск г-ППА-менеджер && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/launchpad-getkeys_0.3.2-1~webupd8~oneiric_all.деб && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/y-ppa-manager_0.0.8.6-1~webupd8~precise_all.деб && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/yad_0.17.1.1-1~webupd8~precise_i386.деб && dpkg Для -я ./*.деб

64 бит:

команды mkdir г-ППА-менеджер && диск г-ППА-менеджер && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/launchpad-getkeys_0.3.2-1~webupd8~oneiric_all.деб && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/y-ppa-manager_0.0.8.6-1~webupd8~precise_all.деб && wget для https://launchpad.net/~webupd8team/+archive/y-ppa-manager/+files/yad_0.17.1.1-1~webupd8~precise_amd64.деб && dpkg Для -я ./*.деб
+440
Moka Soka 3 мая 2015 г., 4:36:34

Я использую ТП-Линк (модель TL-WN723N, версия:2.2) USB-адаптер для подключения к беспроводной сети с помощью Windows 7. Его WEP сети тип шифрования и с помощью ключа безопасности, я могу подключиться к интернету. Но в Ubuntu 12.10 я могу видеть WiFi сети доступен в Сети, но каждый раз, когда я пытаюсь подключиться к нему, он все просит ключ безопасности снова и снова. Я использую правильный ключ безопасности, но он не подключается к сети !

Мне нужно установить правильный драйвер в Ubuntu? Если это как?

Его сбивает с толку, поскольку система показывает, что нет беспроводной сети, сконфигурирует сеть с WEP тип, так кажется, что адаптер работает. Но он не будет подключаться к интернету.

Вывод результата команд lspci

команду lspci
00:00.0 ведущего моста: корпорация Intel 2-го поколения Core семейство процессоров микросхем контроллера (пересм 09)
00:02.0 VGA совместимый контроллер: корпорация Intel 2-го поколения Core семейство процессоров интегрированный графический контроллер (пересм 09)
00:контроллер связи 16.0: корпорация Intel 6 серии/C200 серии семейство наборов микросхем МЭИ контроллер #1 (Ред. 04)
00:1А.0 контроллер по USB: корпорация Intel 6 серии/C200 серии семейство наборов микросхем USB расширенный хост-контроллер #2 (об. 05)
00:1Б.0 Звуковое устройство: корпорация Intel 6-й серии/C200 серии семейство наборов микросхем высокой четкости аудио контроллер (об. 05)
00:1С.0 PCI моста: корпорация Intel 6-й серии/C200 серии семейство наборов микросхем PCI Экспресс корневой порт 1 (об В5)
00:1С.3 слота PCI моста: корпорация Intel 6 серии/C200 серии семейство наборов микросхем PCI Экспресс корневой порт 4 (пересм В5)
00:1д.0 контроллер по USB: корпорация Intel 6 серии/C200 серии семейство наборов микросхем USB расширенный хост-контроллер #1 (об. 05)
00:1Ф.0 ISA мост: корпорация Intel H67 в Express семейство наборов микросхем контроллера ЗЗК (Ред. 05)
00:1Ф.Контроллер SATA 2: корпорация Intel 6-й серии/C200 серии семейство наборов микросхем SATA в режим AHCI контроллер (об. 05)
00:1Ф.3 шины SMBus: корпорация Intel 6-й серии/C200 серии семейство наборов микросхем контроллера шины SM (об. 05)
02:00.0 Ethernet контроллер: Broadcom корпорация Система Netlink BCM57788 локальных сетей гигабита разъема PCIe (Рэв 01)

и вывод команды lsusb

команды lsusb
Устройство автобусных 001 002: код 8087:0024 интегрированный курс корпорация Intel соответствия ступицы
Устройство автобусных 002 002: код 8087:0024 интегрированный курс корпорация Intel соответствия ступицы
Устройство автобусных 001 001: с ID 1d6b:0002 Linux в основу 2.0 корневой концентратор
Устройство автобусных 002 001: с ID 1d6b:0002 Linux в основу 2.0 корневой концентратор
Устройство автобусных 002 003: ИД 0bda:8176 Realtek полупроводника корп RTL8188CUS 802.11 n и адаптер WLAN
Устройство автобусных 002 004: ИД 413c:2107 Делл компьютер корп. 
Устройство автобусных 002 005: ИД 046d:c05a компания Logitech, Инк. Оптическая Мышь М90
+431
Micah Roth 23 июл. 2018 г., 18:59:31

Мне кажется, что с Ubuntu точный Панголин это все, но легко сделать правильную установку вменяемый из источника (ГИТ-РЕПО).

Я нашел другие вопросы сканирования пытается найти ответ на этот, где выход людей написал, кажется, указывают, что они страдают той же проблемой (по незнанию).

Если я запустить на свежей установки Ubuntu 12.04 с составлен вменяемый источник ГИТ я получаю:

$ команды scanimage -в
утилита scanimage (вменяемый-бэкэнд) 1.0.24 ЖКТ; серверная версия 1.0.22

(Я в основном следовал инструкциям на http://ubuntuportal.com/2012/02/how-to-get-an-canon-canoscan-lide-100-scanner-to-work-in-ubuntu-11-10linux-mint-12.html поскольку я не нашел любой другой информации, убедившись в том, что вменяемых не было перед установкой.)

Мой основной интерес-это epson2-бэкэнд. В 1.0.22 он предлагает неправильных установок ТПУ для Epson V700 (TPU2-режим не поддерживается в 1.0.22, и сканер бесполезен для меня, если у меня нет TPU2-поддержка).

Поскольку, если я попрошу его, чтобы войти в режим прозрачности, он показывает 1.0.22 поведения, это означает, что epson2-серверной происходит от 1.0.22 и не 1.0.24, хотя я только что его построил.

Если я установить вменяемую с префиксом в локальную папку и запустить версию команды scanimage он все равно выдает несоответствие.

Однако, на другом компьютере, где установлен специальный 1.0.22 сборки Вменяемый перед обновлением до Ubuntu 12.04, я могу построить и установить то же самое вменяемое-локальный Git-репозиторий, и он правильно подобран модули:

$ ./Вменяемый/ОГРН/команды scanimage -в
утилита scanimage (вменяемый-бэкэнд) 1.0.24 ЖКТ; серверная версия 1.0.24
$ команды scanimage -в
утилита scanimage (санэ-бэкэндов). 1.0.22; серверная версия 1.0.22

На этом компьютере правильно 1.0.24 работает в поиске TPU2 на Epson V700.

Так что я упускаю/делаю не так?

(И я хочу заменить 1.0.22 с 1.0.24 для всей системы в целом, местной сборки был только для отладки.)

Любая помощь будет высоко ценится.

Редактировать 1:

Просто пытался компилировать вменяемый, используя эту инструкцию на Ubuntu 10.04 и он работал как шарм. Однако, когда я обновился до 12.04 (очень хотелось бы запустить 12.04), вменяемый был понижен до 1.0.22. При попытке тот же набор инструкций по 12.04 мне еще повезло-серверной несоответствия был здесь снова (и я у него libusb-dev не установлен)

Правка 2:

Я обновил до Ubuntu 12.10, которая теперь имеет вменяемый 1.0.23 водителей. Я не осмелился пытаюсь скомпилировать из исходников на 12.10 с 1.0.23 является достаточно хорошим для меня. Это просто обойти и все-таки хотелось бы знать, что случилось с Ubuntu 12.04.

Редактировать 3:

Пробовала построить вменяемый на 12.10 как используя выше на Ubuntu-руководство и здания в локальный каталог. Обе попытки произведено серверной Мисс-матч.

+388
derek3191 24 мая 2015 г., 0:25:25

В консоли перейдите в каталог .деб файла.

судо команды dpkg -мне эта программа*
+377
Kricc 8 дек. 2017 г., 21:37:26

Как установить уторрент? Я скачал архив отсюда, добывают его в/Home/brentonhorne/уторрент-сервер-v3_0 и запустить:

компакт-диск /домашний/brentonhorne/уторрент-сервер-v3_0
./utserver

Который занимает меня:

[email protected]Лоро-3500:~$ CD в/дома/brentonhorne/уторрент-сервер-v3_0' 
[email protected]Лоро-3500:~/уторрент-сервер-v3_0$ ./utserver
сервер запущен - через en_AU язык.В UTF-8
Используя en_AU язык.В UTF-8
Файл не найден при проверке целостности: /главная/brentonhorne/уторрент-сервер-v3_0/настройки.дат
Файл не найден при проверке целостности: /главная/brentonhorne/уторрент-сервер-v3_0/настройки.дат.новый
Файл не найден при проверке целостности: /главная/brentonhorne/уторрент-сервер-v3_0/настройки.дат.старый
Файл не найден во время проверки целостности: .//параметры.дат
Файл не найден во время проверки целостности: .//параметры.дат.новый
Файл не найден во время проверки целостности: .//параметры.дат.старый
кэш общий объем физической памяти -1 макс диск 33554432
Файл не найден во время проверки целостности: .//ДГТ.дат
Файл не найден во время проверки целостности: .//ДГТ.дат.новый
Файл не найден во время проверки целостности: .//ДГТ.дат.старый
Файл не найден во время проверки целостности: .//RSS-каналов.дат
Файл не найден во время проверки целостности: .//RSS-каналов.дат.новый
Файл не найден во время проверки целостности: .//RSS-каналов.дат.старый
Файл не найден во время проверки целостности: .//резюме.дат
Установлен IPv6 
Файл не найден во время проверки целостности: .//резюме.дат.новый
Файл не найден во время проверки целостности: .//резюме.дат.старый

В какой момент я застрял и он остается на этом этапе пути уже несколько дней. Я бегу 12.10.

После того, как я побежал

utserver -settingspath /опт/уторрент-сервер-v3_0/

Я получил этот выход:

сервер запущен - через en_AU язык.В UTF-8
Используя en_AU язык.В UTF-8
кэш общий объем физической памяти -1 макс диск 33554432
Загружен ipfilter.дат (0 записи)
Установлен IPv6 

В этот момент он замер так же как это делали с помощью команд, перечисленных выше.

+165
yhayasaka 7 июн. 2012 г., 3:59:32

Это могут быть приостановлены(отключено). Если вы идете к вашему печати консоли, и нажмите правой кнопкой мыши включен, если это не проверено.

Если это не сработает, вам может понадобиться установить драйвер пакет, обновить и переустановить принтер. Который действительно легко, просто отключите USB кабель, удалите его в печать консоль, и подключите его обратно и позволить компьютеру снова откройте его.

+159
Moss 23 мар. 2016 г., 19:37:36

Мой звук больше не работает в Xubuntu 12.04 после работает нормально уже около года. Это произошло сразу после посещения следующей веб-сайт и установка аудио-браузер, приложение для отправки голосовых сэмплов для создания с открытым исходным кодом распознавания речи программы: http://www.voxforge.org/home/read

Я не знаю, если это то, что вызвало проблему, но звук перестал работать примерно в то же время я установил это веб-приложение.

Когда я ввожу в терминале

с PulseAudio -Д

Я получаю следующее:

Э: [новая] главная.с: запуска демона не удалось.

Я пробовал следующие:

суда apt-получить продувки с PulseAudio
судо apt-получить установку с PulseAudio

Когда я тип 'новая' в командной строке, я получаю:

Э: [новая] пид.с: демон уже запущен.
Э: [новая] главная.с: pa_pid_file_create() не удалось.
+126
KalleMP 21 июн. 2013 г., 19:45:15

Я знаю еще один пост, который, используя

apt-получить исходные тексты Linux-изображения-$(uname-Р)

Я могу получить исходный код ядра, но я использую 3.0.0-13-языка-PAE ядра и с помощью команды, я получил это сообщение:

Выбирая для Linux-языка в качестве исходного пакета вместо Linux-образ-3.0.0-13-языка-Паэ'

Поэтому, я буду признателен за любую помощь, надеюсь, что кто-то знает, где она может находиться.

Спасибо всем заранее.

+119
Linda Orowtiz 2 мая 2014 г., 5:07:47

Первый вариант-черный с Ubuntu 12.04. Остальные только для проверки компьютера.

+41
Sam Slapi 11 апр. 2011 г., 8:45:38

Показать вопросы с тегом